#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w+ \w+ \(OBJECT\) \@[a-z0-9]+"
Local $sString = "SCALAR_NaN ceil (SCALAR_NaN) @7ff710295590" & @CRLF & _
"SCALAR waypointVisible (ARRAY) @7ff70f56e030" & @CRLF & _
"NOTHING enableSatNormalOnDetail (BOOL) @7ff70f1a0d90" & @CRLF & _
"ARRAY getPosATL (OBJECT) @7ff70f1e9df0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")