import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+ \\w+ \\(OBJECT\\) \\@[a-z0-9]+";
final String string = "SCALAR_NaN ceil (SCALAR_NaN) @7ff710295590\n"
+ "SCALAR waypointVisible (ARRAY) @7ff70f56e030\n"
+ "NOTHING enableSatNormalOnDetail (BOOL) @7ff70f1a0d90\n"
+ "ARRAY getPosATL (OBJECT) @7ff70f1e9df0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}