import Foundation
let pattern = #"^[A-Z0-9\+\/]*=?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"UABHAFMAUABvAHIAdABhAGwALgBQAEcAUwBBAHUAdABoAFMAZQByAHYAaQBjAGUALgBQAGEAcwBzAHcAbwByAGQAUgBlAHMAZQB0AFIAZQBxAHUAZQBzAHQASQBuAHQAZQByAG4AYQBsACAAKABBAHAAcABTAGUAcwBzAGkAbwBuAFUASQBEACAAewA5ADAAMgA0ADUAQgA0ADEALQAzADgAMABCAC0ANABDAEQANAAtADkAQQA4ADIALQA0AEQAOQAzADMARAA5ADEAMAAwADMANQB9ACwAIABNAGUAdABoAG8AZABUAHkAcABlACAAewBFAE0AQQBJAEwAfQAsACAAVQBzAGUAcgBuAGEAbQBlACAAewB3AHIAYwBAAG0AYQBpAGwALgBuAGUAdAB9ACwAIABBAHUAdABoAFMAZQByAHYAaQBjAGUAVQBJAEQAIAB7ADgARAAyADEAQwBBADMAOQAtAEEAMwBFADQALQA0ADIAQwA0AC0AQQAyAEEANAAtADkAOABFADMAQwBDADEARQBDADIAMQBBAH0AKQA="#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}