using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z0-9\+\/]*=?$";
string input = @"UABHAFMAUABvAHIAdABhAGwALgBQAEcAUwBBAHUAdABoAFMAZQByAHYAaQBjAGUALgBQAGEAcwBzAHcAbwByAGQAUgBlAHMAZQB0AFIAZQBxAHUAZQBzAHQASQBuAHQAZQByAG4AYQBsACAAKABBAHAAcABTAGUAcwBzAGkAbwBuAFUASQBEACAAewA5ADAAMgA0ADUAQgA0ADEALQAzADgAMABCAC0ANABDAEQANAAtADkAQQA4ADIALQA0AEQAOQAzADMARAA5ADEAMAAwADMANQB9ACwAIABNAGUAdABoAG8AZABUAHkAcABlACAAewBFAE0AQQBJAEwAfQAsACAAVQBzAGUAcgBuAGEAbQBlACAAewB3AHIAYwBAAG0AYQBpAGwALgBuAGUAdAB9ACwAIABBAHUAdABoAFMAZQByAHYAaQBjAGUAVQBJAEQAIAB7ADgARAAyADEAQwBBADMAOQAtAEEAMwBFADQALQA0ADIAQwA0AC0AQQAyAEEANAAtADkAOABFADMAQwBDADEARQBDADIAMQBBAH0AKQA=";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}