const regex = /^[A-Z0-9\+\/]*=?$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z0-9\\+\\\/]*=?$', 'i')
const str = `UABHAFMAUABvAHIAdABhAGwALgBQAEcAUwBBAHUAdABoAFMAZQByAHYAaQBjAGUALgBQAGEAcwBzAHcAbwByAGQAUgBlAHMAZQB0AFIAZQBxAHUAZQBzAHQASQBuAHQAZQByAG4AYQBsACAAKABBAHAAcABTAGUAcwBzAGkAbwBuAFUASQBEACAAewA5ADAAMgA0ADUAQgA0ADEALQAzADgAMABCAC0ANABDAEQANAAtADkAQQA4ADIALQA0AEQAOQAzADMARAA5ADEAMAAwADMANQB9ACwAIABNAGUAdABoAG8AZABUAHkAcABlACAAewBFAE0AQQBJAEwAfQAsACAAVQBzAGUAcgBuAGEAbQBlACAAewB3AHIAYwBAAG0AYQBpAGwALgBuAGUAdAB9ACwAIABBAHUAdABoAFMAZQByAHYAaQBjAGUAVQBJAEQAIAB7ADgARAAyADEAQwBBADMAOQAtAEEAMwBFADQALQA0ADIAQwA0AC0AQQAyAEEANAAtADkAOABFADMAQwBDADEARQBDADIAMQBBAH0AKQA=`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}