// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^[A-Z0-9\+\/]*=?$").unwrap();
let string = "UABHAFMAUABvAHIAdABhAGwALgBQAEcAUwBBAHUAdABoAFMAZQByAHYAaQBjAGUALgBQAGEAcwBzAHcAbwByAGQAUgBlAHMAZQB0AFIAZQBxAHUAZQBzAHQASQBuAHQAZQByAG4AYQBsACAAKABBAHAAcABTAGUAcwBzAGkAbwBuAFUASQBEACAAewA5ADAAMgA0ADUAQgA0ADEALQAzADgAMABCAC0ANABDAEQANAAtADkAQQA4ADIALQA0AEQAOQAzADMARAA5ADEAMAAwADMANQB9ACwAIABNAGUAdABoAG8AZABUAHkAcABlACAAewBFAE0AQQBJAEwAfQAsACAAVQBzAGUAcgBuAGEAbQBlACAAewB3AHIAYwBAAG0AYQBpAGwALgBuAGUAdAB9ACwAIABBAHUAdABoAFMAZQByAHYAaQBjAGUAVQBJAEQAIAB7ADgARAAyADEAQwBBADMAOQAtAEEAMwBFADQALQA0ADIAQwA0AC0AQQAyAEEANAAtADkAOABFADMAQwBDADEARQBDADIAMQBBAH0AKQA=";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}