import Foundation
let pattern = #"(^(feature)\/\d+$)|^(hotfix|release)\/\d+\.\d+\.\d+$|^develop$|^master$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
feature
feature/
feature/asdf
feature/123
bugfix
bugfix/
bugfix/asdf
bugfix/123
temp
temp/
temp/123
temp/abc
temp/123abc
temp/123.abc
temp/123.123
hotfix
hotfix/
hotfix/abc
hotfix/123
hotfix/1.0.0
hotfix/11.11.11
release
release/
release/abc
release/123
release/1.0.0
release/11.11.11
support
support/
support/abc
support/123
support/1.0.0
support/11.11.11
support/1.x
develop
master
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)