# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^(feature)\/\d+$)|^(hotfix|release)\/\d+\.\d+\.\d+$|^develop$|^master$"
test_str = ("feature\n"
"feature/\n"
"feature/asdf\n"
"feature/123\n"
"bugfix\n"
"bugfix/\n"
"bugfix/asdf\n"
"bugfix/123\n"
"temp\n"
"temp/\n"
"temp/123\n"
"temp/abc\n"
"temp/123abc\n"
"temp/123.abc\n"
"temp/123.123\n"
"hotfix\n"
"hotfix/\n"
"hotfix/abc\n"
"hotfix/123\n"
"hotfix/1.0.0\n"
"hotfix/11.11.11\n"
"release\n"
"release/\n"
"release/abc\n"
"release/123\n"
"release/1.0.0\n"
"release/11.11.11\n"
"support\n"
"support/\n"
"support/abc\n"
"support/123\n"
"support/1.0.0\n"
"support/11.11.11\n"
"support/1.x\n"
"develop\n"
"master")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.