$re = '/(^(feature)\/\d+$)|^(hotfix|release)\/\d+\.\d+\.\d+$|^develop$|^master$/m';
$str = 'feature
feature/
feature/asdf
feature/123
bugfix
bugfix/
bugfix/asdf
bugfix/123
temp
temp/
temp/123
temp/abc
temp/123abc
temp/123.abc
temp/123.123
hotfix
hotfix/
hotfix/abc
hotfix/123
hotfix/1.0.0
hotfix/11.11.11
release
release/
release/abc
release/123
release/1.0.0
release/11.11.11
support
support/
support/abc
support/123
support/1.0.0
support/11.11.11
support/1.x
develop
master';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);