use strict;
my $str = 'feature
feature/
feature/asdf
feature/123
bugfix
bugfix/
bugfix/asdf
bugfix/123
temp
temp/
temp/123
temp/abc
temp/123abc
temp/123.abc
temp/123.123
hotfix
hotfix/
hotfix/abc
hotfix/123
hotfix/1.0.0
hotfix/11.11.11
release
release/
release/abc
release/123
release/1.0.0
release/11.11.11
support
support/
support/abc
support/123
support/1.0.0
support/11.11.11
support/1.x
develop
master';
my $regex = qr/(^(feature)\/\d+$)|^(hotfix|release)\/\d+\.\d+\.\d+$|^develop$|^master$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}