import Foundation
let pattern = #"src=["|']?((?:https?:\/\/)?(?:www\.)?([^\/]+)([^\?|^"|^'|^\s]*))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<iframe width="420" height="315" src="https://www.youtube.com/embed/S6psuUt8caM" frameborder="0" allowfullscreen></iframe>
<iframe width="420" height="315" src='https://www.youtube.com/embed/S6psuUt8caM' frameborder="0" allowfullscreen></iframe>
<iframe width="420" height="315" src=https://www.youtube.com/embed/S6psuUt8caM frameborder="0" allowfullscreen></iframe>
<iframe src="http://livestream.com/accounts/2600567/events/3949236/videos/85086024/player?autoPlay=false&height=360&mute=false&width=640" width="640" height="360" frameborder="0" scrolling="no"></iframe>
<iframe src="https://player.vimeo.com/video/130848521?color=ffffff&badge=0" width="500" height="281" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe> <p><a href="https://vimeo.com/130848521">samuel-613</a> from <a href="https://vimeo.com/billylumby">Billy Lumby</a> on <a href="https://vimeo.com">Vimeo</a>.</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)