const regex = /src=["|']?((?:https?:\/\/)?(?:www\.)?([^\/]+)([^\?|^"|^'|^\s]*))/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('src=["|\']?((?:https?:\\\/\\\/)?(?:www\\.)?([^\\\/]+)([^\\?|^"|^\'|^\\s]*))', 'igm')
const str = `<iframe width="420" height="315" src="https://www.youtube.com/embed/S6psuUt8caM" frameborder="0" allowfullscreen></iframe>
<iframe width="420" height="315" src='https://www.youtube.com/embed/S6psuUt8caM' frameborder="0" allowfullscreen></iframe>
<iframe width="420" height="315" src=https://www.youtube.com/embed/S6psuUt8caM frameborder="0" allowfullscreen></iframe>
<iframe src="http://livestream.com/accounts/2600567/events/3949236/videos/85086024/player?autoPlay=false&height=360&mute=false&width=640" width="640" height="360" frameborder="0" scrolling="no"></iframe>
<iframe src="https://player.vimeo.com/video/130848521?color=ffffff&badge=0" width="500" height="281" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe> <p><a href="https://vimeo.com/130848521">samuel-613</a> from <a href="https://vimeo.com/billylumby">Billy Lumby</a> on <a href="https://vimeo.com">Vimeo</a>.</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}