$re = '/src=["|\']?((?:https?:\/\/)?(?:www\.)?([^\/]+)([^\?|^"|^\'|^\s]*))/im';
$str = '<iframe width="420" height="315" src="https://www.youtube.com/embed/S6psuUt8caM" frameborder="0" allowfullscreen></iframe>
<iframe width="420" height="315" src=\'https://www.youtube.com/embed/S6psuUt8caM\' frameborder="0" allowfullscreen></iframe>
<iframe width="420" height="315" src=https://www.youtube.com/embed/S6psuUt8caM frameborder="0" allowfullscreen></iframe>
<iframe src="http://livestream.com/accounts/2600567/events/3949236/videos/85086024/player?autoPlay=false&height=360&mute=false&width=640" width="640" height="360" frameborder="0" scrolling="no"></iframe>
<iframe src="https://player.vimeo.com/video/130848521?color=ffffff&badge=0" width="500" height="281" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe> <p><a href="https://vimeo.com/130848521">samuel-613</a> from <a href="https://vimeo.com/billylumby">Billy Lumby</a> on <a href="https://vimeo.com">Vimeo</a>.</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);