import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "src=[\"|']?((?:https?:\\/\\/)?(?:www\\.)?([^\\/]+)([^\\?|^\"|^'|^\\s]*))";
final String string = "<iframe width=\"420\" height=\"315\" src=\"https://www.youtube.com/embed/S6psuUt8caM\" frameborder=\"0\" allowfullscreen></iframe>\n"
+ "<iframe width=\"420\" height=\"315\" src='https://www.youtube.com/embed/S6psuUt8caM' frameborder=\"0\" allowfullscreen></iframe>\n"
+ "<iframe width=\"420\" height=\"315\" src=https://www.youtube.com/embed/S6psuUt8caM frameborder=\"0\" allowfullscreen></iframe>\n"
+ "<iframe src=\"http://livestream.com/accounts/2600567/events/3949236/videos/85086024/player?autoPlay=false&height=360&mute=false&width=640\" width=\"640\" height=\"360\" frameborder=\"0\" scrolling=\"no\"></iframe>\n"
+ "<iframe src=\"https://player.vimeo.com/video/130848521?color=ffffff&badge=0\" width=\"500\" height=\"281\" frameborder=\"0\" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe> <p><a href=\"https://vimeo.com/130848521\">samuel-613</a> from <a href=\"https://vimeo.com/billylumby\">Billy Lumby</a> on <a href=\"https://vimeo.com\">Vimeo</a>.</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}