// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)<\s*tag[^>]*>(.*?)<\s*\/\s*tag>").unwrap();
let string = "<tag attribute=\"attr\"> text </tag>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}