package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<\s*tag[^>]*>(.*?)<\s*\/\s*tag>`)
var str = `<tag attribute="attr"> text </tag>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}