$re = '/<\s*tag[^>]*>(.*?)<\s*\/\s*tag>/mi';
$str = '<tag attribute="attr"> text </tag>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);