re = /<\s*tag[^>]*>(.*?)<\s*\/\s*tag>/mi
str = '<tag attribute="attr"> text </tag>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end