import Foundation
let pattern = #"\(([1-9][\d\-\s,]*[0-9])\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Headaches, intracranial hypertension, papilledema and exophthalmos may occur with intracranial infiltration.(7-15, 8)
(234---345)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span class="ref">$1</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)