// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\(([1-9][\d\-\s,]*[0-9])\)").unwrap();
let string = "Headaches, intracranial hypertension, papilledema and exophthalmos may occur with intracranial infiltration.(7-15, 8)
(234---345)";
let substitution = "<span class=\"ref\">$1</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}