$re = '/\(([1-9][\d\-\s,]*[0-9])\)/';
$str = 'Headaches, intracranial hypertension, papilledema and exophthalmos may occur with intracranial infiltration.(7-15, 8)
(234---345)';
$subst = "<span class=\"ref\">$1</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;