package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(([1-9][\d\-\s,]*[0-9])\)`)
var str = `Headaches, intracranial hypertension, papilledema and exophthalmos may occur with intracranial infiltration.(7-15, 8)
(234---345)`
var substitution = "<span class="ref">$1</span>"
fmt.Println(re.ReplaceAllString(str, substitution))
}