import Foundation
let pattern = #"(… )|( \[-\])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""Massage, Rückenmassage, Heilmassage, Wellness Massage, Fußmassage, Fußreflexzonenmassage, Heilpraktiker,… Berlin, Osteopathie, Manuelle Lymphdrainage, Charlottenburg, Ohrakupunktur, Medizinische Massage, Spannungskopfschmerz, Heilpraktiker Akupunktur, Firmenmassage, Behandlung von Rückenbeschwerden, Tiefengewebemassage, Schlüsselzonenmassage nach Dr. Marnitz, Behandlung von Spannungskopfschmerzen, Massage-Praxen, Staatlich Geprüfte Masseure, Heilpraktiker für Ohrakupunktur, Atembehandlung nach Middendorf, Schlüsselzonenmassagen nach Dr. Marnitz Berlin, Osteopathie, Manuelle Lymphdrainage, Charlottenburg, Ohrakupunktur, Medizinische Massage, Spannungskopfschmerz, Heilpraktiker Akupunktur, Firmenmassage, Behandlung von Rückenbeschwerden, Tiefengewebemassage, Schlüsselzonenmassage nach Dr. Marnitz, Behandlung von Spannungskopfschmerzen, Massage-Praxen, Staatlich Geprüfte Masseure, Heilpraktiker für Ohrakupunktur, Atembehandlung nach Middendorf, Schlüsselzonenmassagen nach Dr. Marnitzweniger [-]""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)