using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(… )|( \[-\])";
string input = @"""Massage, Rückenmassage, Heilmassage, Wellness Massage, Fußmassage, Fußreflexzonenmassage, Heilpraktiker,… Berlin, Osteopathie, Manuelle Lymphdrainage, Charlottenburg, Ohrakupunktur, Medizinische Massage, Spannungskopfschmerz, Heilpraktiker Akupunktur, Firmenmassage, Behandlung von Rückenbeschwerden, Tiefengewebemassage, Schlüsselzonenmassage nach Dr. Marnitz, Behandlung von Spannungskopfschmerzen, Massage-Praxen, Staatlich Geprüfte Masseure, Heilpraktiker für Ohrakupunktur, Atembehandlung nach Middendorf, Schlüsselzonenmassagen nach Dr. Marnitz Berlin, Osteopathie, Manuelle Lymphdrainage, Charlottenburg, Ohrakupunktur, Medizinische Massage, Spannungskopfschmerz, Heilpraktiker Akupunktur, Firmenmassage, Behandlung von Rückenbeschwerden, Tiefengewebemassage, Schlüsselzonenmassage nach Dr. Marnitz, Behandlung von Spannungskopfschmerzen, Massage-Praxen, Staatlich Geprüfte Masseure, Heilpraktiker für Ohrakupunktur, Atembehandlung nach Middendorf, Schlüsselzonenmassagen nach Dr. Marnitzweniger [-]""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}