#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(… )|( \[-\])"
Local $sString = ""Massage, Rückenmassage, Heilmassage, Wellness Massage, Fußmassage, Fußreflexzonenmassage, Heilpraktiker,… Berlin, Osteopathie, Manuelle Lymphdrainage, Charlottenburg, Ohrakupunktur, Medizinische Massage, Spannungskopfschmerz, Heilpraktiker Akupunktur, Firmenmassage, Behandlung von Rückenbeschwerden, Tiefengewebemassage, Schlüsselzonenmassage nach Dr. Marnitz, Behandlung von Spannungskopfschmerzen, Massage-Praxen, Staatlich Geprüfte Masseure, Heilpraktiker für Ohrakupunktur, Atembehandlung nach Middendorf, Schlüsselzonenmassagen nach Dr. Marnitz Berlin, Osteopathie, Manuelle Lymphdrainage, Charlottenburg, Ohrakupunktur, Medizinische Massage, Spannungskopfschmerz, Heilpraktiker Akupunktur, Firmenmassage, Behandlung von Rückenbeschwerden, Tiefengewebemassage, Schlüsselzonenmassage nach Dr. Marnitz, Behandlung von Spannungskopfschmerzen, Massage-Praxen, Staatlich Geprüfte Masseure, Heilpraktiker für Ohrakupunktur, Atembehandlung nach Middendorf, Schlüsselzonenmassagen nach Dr. Marnitzweniger [-]""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")