const regex = /(… )|( \[-\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(… )|( \\[-\\])', 'g')
const str = `"Massage, Rückenmassage, Heilmassage, Wellness Massage, Fußmassage, Fußreflexzonenmassage, Heilpraktiker,… Berlin, Osteopathie, Manuelle Lymphdrainage, Charlottenburg, Ohrakupunktur, Medizinische Massage, Spannungskopfschmerz, Heilpraktiker Akupunktur, Firmenmassage, Behandlung von Rückenbeschwerden, Tiefengewebemassage, Schlüsselzonenmassage nach Dr. Marnitz, Behandlung von Spannungskopfschmerzen, Massage-Praxen, Staatlich Geprüfte Masseure, Heilpraktiker für Ohrakupunktur, Atembehandlung nach Middendorf, Schlüsselzonenmassagen nach Dr. Marnitz Berlin, Osteopathie, Manuelle Lymphdrainage, Charlottenburg, Ohrakupunktur, Medizinische Massage, Spannungskopfschmerz, Heilpraktiker Akupunktur, Firmenmassage, Behandlung von Rückenbeschwerden, Tiefengewebemassage, Schlüsselzonenmassage nach Dr. Marnitz, Behandlung von Spannungskopfschmerzen, Massage-Praxen, Staatlich Geprüfte Masseure, Heilpraktiker für Ohrakupunktur, Atembehandlung nach Middendorf, Schlüsselzonenmassagen nach Dr. Marnitzweniger [-]"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}