re = /("(?i)(?<Type>availableBalance)")\s*:\s*"?(?<Value>[^\n"]*)"?/m
str = '{
"availableBalance": "Super hero squad",
"homeTown": "Metro City",
"availableBalance": 2016,
"secretBase": "Super tower",
"active": true
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end