package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)("(?i)(?<Type>availableBalance)")\s*:\s*"?(?<Value>[^\n"]*)"?`)
var str = `{
"availableBalance": "Super hero squad",
"homeTown": "Metro City",
"availableBalance": 2016,
"secretBase": "Super tower",
"active": true
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}