$re = '/("(?i)(?<Type>availableBalance)")\s*:\s*"?(?<Value>[^\n"]*)"?/m';
$str = '{
"availableBalance": "Super hero squad",
"homeTown": "Metro City",
"availableBalance": 2016,
"secretBase": "Super tower",
"active": true
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);