#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)("(?i)(?<Type>availableBalance)")\s*:\s*"?(?<Value>[^\n"]*)"?"
Local $sString = "{" & @CRLF & _
" "availableBalance": "Super hero squad"," & @CRLF & _
" "homeTown": "Metro City"," & @CRLF & _
" "availableBalance": 2016," & @CRLF & _
" "secretBase": "Super tower"," & @CRLF & _
" "active": true" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")