$re = '/<\s*script\s+.+?(?=src\s*=\s*[\'"]).+?(?=.bundle.js).bundle.js\s*["\'](?:\s*>|\s*\/\s*>)(?:\s*<\s*\/\s*script\s*>)?/i';
$str = '<script type="text/javascript" src="inline.a4f139a42f2ec94463d6.bundle.js"></script>
<script type="text/javascript" src="polyfills.456a9bac641ef5f0139a.bundle.js"></script><script type="text/javascript" src="sw-register.b73048fe3d9f8a1e7ae5.bundle.js"></script>
<script>
</script>
<script type="text/javascript" src="vendor.8fa530543a5178055143.bundle.js"></script>
<script type="text/javascript" src="main.196eab45c86ac53c856e.bundle.js"></script>
</body>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);