import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\s*script\\s+.+?(?=src\\s*=\\s*['\"]).+?(?=.bundle.js).bundle.js\\s*[\"'](?:\\s*>|\\s*\\/\\s*>)(?:\\s*<\\s*\\/\\s*script\\s*>)?";
final String string = "<script type=\"text/javascript\" src=\"inline.a4f139a42f2ec94463d6.bundle.js\"></script>\n"
+ "<script type=\"text/javascript\" src=\"polyfills.456a9bac641ef5f0139a.bundle.js\"></script><script type=\"text/javascript\" src=\"sw-register.b73048fe3d9f8a1e7ae5.bundle.js\"></script>\n"
+ "<script>\n"
+ "</script>\n"
+ "<script type=\"text/javascript\" src=\"vendor.8fa530543a5178055143.bundle.js\"></script>\n"
+ "<script type=\"text/javascript\" src=\"main.196eab45c86ac53c856e.bundle.js\"></script>\n"
+ "</body>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}