using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\s*script\s+.+?(?=src\s*=\s*['""]).+?(?=.bundle.js).bundle.js\s*[""'](?:\s*>|\s*\/\s*>)(?:\s*<\s*\/\s*script\s*>)?";
string input = @"<script type=""text/javascript"" src=""inline.a4f139a42f2ec94463d6.bundle.js""></script>
<script type=""text/javascript"" src=""polyfills.456a9bac641ef5f0139a.bundle.js""></script><script type=""text/javascript"" src=""sw-register.b73048fe3d9f8a1e7ae5.bundle.js""></script>
<script>
</script>
<script type=""text/javascript"" src=""vendor.8fa530543a5178055143.bundle.js""></script>
<script type=""text/javascript"" src=""main.196eab45c86ac53c856e.bundle.js""></script>
</body>
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}