use strict;
my $str = '<script type="text/javascript" src="inline.a4f139a42f2ec94463d6.bundle.js"></script>
<script type="text/javascript" src="polyfills.456a9bac641ef5f0139a.bundle.js"></script><script type="text/javascript" src="sw-register.b73048fe3d9f8a1e7ae5.bundle.js"></script>
<script>
</script>
<script type="text/javascript" src="vendor.8fa530543a5178055143.bundle.js"></script>
<script type="text/javascript" src="main.196eab45c86ac53c856e.bundle.js"></script>
</body>
';
my $regex = qr/<\s*script\s+.+?(?=src\s*=\s*['"]).+?(?=.bundle.js).bundle.js\s*["'](?:\s*>|\s*\/\s*>)(?:\s*<\s*\/\s*script\s*>)?/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}