import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/(.?[^\\.]*)\\.(.?[^\\/]*)\\/(.*)";
final String string = "https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Cu_Geology/JGE_Template_20201022.gdb.zip\n"
+ "https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Cu_Geology/pCu_Geology.gdb.zip\n"
+ "https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Pet_Reservoir/JGE_Template_20201026.gdb.zip\n"
+ "https://jge-data-platform-primary-automation-prod.s3.amazonaws.com/DKU_TSHIRTS/orders_copy/out-s0.csv.gz";
final String subst = "\\1|||\\2|||\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}