# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/https:\\/\\/(.?[^\.]*)\.(.?[^\\/]*)\\/(.*)/\1|||\2|||\3/gm;t' <<< "https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Cu_Geology/JGE_Template_20201022.gdb.zip
https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Cu_Geology/pCu_Geology.gdb.zip
https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Pet_Reservoir/JGE_Template_20201026.gdb.zip
https://jge-data-platform-primary-automation-prod.s3.amazonaws.com/DKU_TSHIRTS/orders_copy/out-s0.csv.gz"