#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)https:\/\/(.?[^\.]*)\.(.?[^\/]*)\/(.*)"
Local $sString = "https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Cu_Geology/JGE_Template_20201022.gdb.zip" & @CRLF & _
"https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Cu_Geology/pCu_Geology.gdb.zip" & @CRLF & _
"https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Pet_Reservoir/JGE_Template_20201026.gdb.zip" & @CRLF & _
"https://jge-data-platform-primary-automation-prod.s3.amazonaws.com/DKU_TSHIRTS/orders_copy/out-s0.csv.gz"
Local $sSubst = "\1|||\2|||\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)