re = /^(?=.*?[+-])(?=.*?[0-9]).[0-9]+$/m
str = '+343
asdf.
23fsdf
as334
-122
.4487
|5445
-
+
+23.23
-23,23
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end