using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*?[+-])(?=.*?[0-9]).[0-9]+$";
string input = @"+343
asdf.
23fsdf
as334
-122
.4487
|5445
-
+
+23.23
-23,23
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}