import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*?[+-])(?=.*?[0-9]).[0-9]+$";
final String string = "+343\n"
+ "asdf.\n"
+ "23fsdf\n"
+ "as334\n"
+ "-122\n"
+ ".4487\n"
+ "|5445\n"
+ "-\n"
+ "+\n"
+ "+23.23\n"
+ "-23,23\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}