$re = '/^(?=.*?[+-])(?=.*?[0-9]).[0-9]+$/m';
$str = '+343
asdf.
23fsdf
as334
-122
.4487
|5445
-
+
+23.23
-23,23
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);