$re = '/(20[0-9]{2}-[0-9]{2}-[0-9]{2}T[0-9]{2}:[0-9]{2})((-|\+)[0-9]{2}:[0-9]{2}|)\[(\w+\/*\w*)]/';
$str = '2015-08-30T16:00[America/Phoenix]
2015-08-30T16:00[America]
2015-08-30T16:00-07:00[America/Phoenix]
2015-08-30T16:00+07:00[America/Phoenix]
2015-08-30T16:00-07:00[America]
2015-08-30T16:00+07:00[America]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);