package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(20[0-9]{2}-[0-9]{2}-[0-9]{2}T[0-9]{2}:[0-9]{2})((-|\+)[0-9]{2}:[0-9]{2}|)\[(\w+\/*\w*)]`)
var str = `2015-08-30T16:00[America/Phoenix]
2015-08-30T16:00[America]
2015-08-30T16:00-07:00[America/Phoenix]
2015-08-30T16:00+07:00[America/Phoenix]
2015-08-30T16:00-07:00[America]
2015-08-30T16:00+07:00[America]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}