const regex = /(20[0-9]{2}-[0-9]{2}-[0-9]{2}T[0-9]{2}:[0-9]{2})((-|\+)[0-9]{2}:[0-9]{2}|)\[(\w+\/*\w*)]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(20[0-9]{2}-[0-9]{2}-[0-9]{2}T[0-9]{2}:[0-9]{2})((-|\\+)[0-9]{2}:[0-9]{2}|)\\[(\\w+\\\/*\\w*)]', 'g')
const str = `2015-08-30T16:00[America/Phoenix]
2015-08-30T16:00[America]
2015-08-30T16:00-07:00[America/Phoenix]
2015-08-30T16:00+07:00[America/Phoenix]
2015-08-30T16:00-07:00[America]
2015-08-30T16:00+07:00[America]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}