#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(20[0-9]{2}-[0-9]{2}-[0-9]{2}T[0-9]{2}:[0-9]{2})((-|\+)[0-9]{2}:[0-9]{2}|)\[(\w+\/*\w*)]"
Local $sString = "2015-08-30T16:00[America/Phoenix]" & @CRLF & _
"2015-08-30T16:00[America]" & @CRLF & _
"2015-08-30T16:00-07:00[America/Phoenix]" & @CRLF & _
"2015-08-30T16:00+07:00[America/Phoenix]" & @CRLF & _
"2015-08-30T16:00-07:00[America]" & @CRLF & _
"2015-08-30T16:00+07:00[America]" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")