// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9]{0,1}\.*[0-9]{0,3},[0-9]{2,2}$").unwrap();
let string = "102,00
103,78
1.000,34
11.000,00
11.000,10
100,10";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}