import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]{0,1}\\.*[0-9]{0,3},[0-9]{2,2}$";
final String string = "102,00\n"
+ "103,78\n"
+ "1.000,34\n"
+ "11.000,00\n"
+ "11.000,10\n"
+ "100,10";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}