$re = '/^[0-9]{0,1}\.*[0-9]{0,3},[0-9]{2,2}$/m';
$str = '102,00
103,78
1.000,34
11.000,00
11.000,10
100,10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);