using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9]{0,1}\.*[0-9]{0,3},[0-9]{2,2}$";
string input = @"102,00
103,78
1.000,34
11.000,00
11.000,10
100,10";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}