// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\+?\s?7\s?\(?-?(?# code)[0-9]{3}(?# next 3 digit)\s?\)?-?\s?[0-9]{3}\s?-?(?# next 2 digits)[0-9]{2}\s?-?(?# the last 2 digits)[0-9]{2}").unwrap();
let string = "79001234567
7 900 1234567
7 900 123 45 67
7-900-123-45-67
7 900 123-45-67
7900 123-45-67
7(900)1234567
7 (900) 123 45 67
7 (900) 123-45-67
+79001234567
+7 900 123 45 67
+7 (900) 123-45-67";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}